Important information on the OpenSSL “Heartbleed” Vulnerability

ACPE's website does not use OpenSSL and no account information was impacted by this vulnerability. However, customers are advised to update their password if they use the same password on other sites affected by this vulnerability. Review this list (Mashable.com) of commonly used websites to determine if they were impacted by the OpenSSL “Heartbleed” vulnerability. Regardless of whether you think you may be impacted, it’s always a good idea to update passwords regularly in order to help protect your personal information.